Back to overview
Degraded
Incident with upstream provider
Mar 17, 2026 at 4:00pm UTC
Affected services
Studio
API
Proxy
Resolved
Mar 17, 2026 at 11:46pm UTC
Our upstream provider has resolved their incident. Imagine should be functioning properly again.
Affected services
Created
Mar 17, 2026 at 4:00pm UTC
There is an incident with an upstream provider that is affecting Imagine.
Affected services