Back to overview
Degraded
Previews not loading
Mar 14, 2026 at 1:14am UTC
Affected services
Sandboxes
Resolved
Mar 16, 2026 at 4:09pm UTC
We've made improvements to the preview and are continuing to monitor.
Affected services
Created
Mar 14, 2026 at 1:14am UTC
Our engineering team is investigating an issue with previews not loading. We apologize for the inconvenience.
Affected services